返回列表 發帖

利用兩台Mikrotik Router的switch晶片橋接IPTV與網路

本帖最後由 gfx86674 於 2019-8-5 13:57 編輯

在家中橋接網通設備,若中間置入台MOD(IPTV,透過Modem multicast發送)是個很頭痛的問題.
但若是分享器或交換器支援vlan,就容易的多.

以下是用RB450G+RB750GL建置:

因這兩台Router的內部交換機晶片可處理vlan標記,
所以就不再使用軟體的bridge ,而是用switch chip.
  1. #RB450G
  2. /interface bridge add name=bridge

  3. /interface bridge port
  4. add bridge=bridge interface=ether1 hw=yes
  5. add bridge=bridge interface=ether2 hw=yes
  6. add bridge=bridge interface=ether3 hw=yes
  7. add bridge=bridge interface=ether4 hw=yes
  8. add bridge=bridge interface=ether5 hw=yes

  9. /interface ethernet switch port
  10. set ether5 vlan-header=add-if-missing vlan-mode=fallback
  11. set ether1 default-vlan-id=100 vlan-header=always-strip vlan-mode=fallback
  12. set ether2 default-vlan-id=200 vlan-header=always-strip vlan-mode=fallback
  13. set ether3 default-vlan-id=200 vlan-header=always-strip vlan-mode=fallback
  14. set ether4 default-vlan-id=100 vlan-header=always-strip vlan-mode=fallback
  15. set switch1-cpu vlan-header=add-if-missing vlan-mode=fallback

  16. /interface ethernet switch vlan
  17. add ports=ether5,ether1,ether4,switch1-cpu switch=switch1 vlan-id=100
  18. add ports=ether5,ether2,ether3,switch1-cpu switch=switch1 vlan-id=200

  19. /interface vlan
  20. add name=wan vlan-id=100 interface=bridge
  21. add name=lan vlan-id=200 interface=bridge

  22. /ip address
  23. add address=192.168.88.1/24 interface=lan network=192.168.88.0

  24. /ip dhcp-server
  25. add address-pool=dhcp-pool authoritative=after-2sec-delay interface=lan name=DHCP

  26. /interface pppoe-client
  27. add allow=pap interface=wan keepalive-timeout=60 profile=default name=pppoe-out1 password=xxxx user=xxxx
複製代碼
  1. #RB750GL
  2. /interface bridge add name=bridge

  3. /interface bridge port
  4. add bridge=bridge interface=ether1 hw=yes
  5. add bridge=bridge interface=ether2 hw=yes
  6. add bridge=bridge interface=ether3 hw=yes
  7. add bridge=bridge interface=ether4 hw=yes
  8. add bridge=bridge interface=ether5 hw=yes

  9. /interface ethernet switch port
  10. set ether5 vlan-header=add-if-missing vlan-mode=fallback
  11. set ether1 default-vlan-id=200 vlan-header=always-strip vlan-mode=fallback
  12. set ether2 default-vlan-id=200 vlan-header=always-strip vlan-mode=fallback
  13. set ether3 default-vlan-id=200 vlan-header=always-strip vlan-mode=fallback
  14. set ether4 default-vlan-id=100 vlan-header=always-strip vlan-mode=fallback
  15. set switch1_cpu vlan-header=add-if-missing vlan-mode=fallback

  16. /interface ethernet switch vlan
  17. add ports=ether5,ether4,switch1-cpu switch=switch1 vlan-id=100
  18. add ports=ether5,ether1,ether2,ether3,switch1-cpu switch=switch1 vlan-id=200

  19. /interface vlan
  20. add name=lan vlan-id=200 interface=bridge

  21. /ip address
  22. add address=192.168.88.2/24 interface=lan network=192.168.88.0
複製代碼
附件: 您需要登錄才可以下載或查看附件。沒有帳號?註冊

本帖最後由 gfx86674 於 2019-7-25 11:46 編輯

若橋接的不是RB750GL,而是Netgear GS105E呢?





附件: 您需要登錄才可以下載或查看附件。沒有帳號?註冊

TOP

回復 17# gfx86674


感謝大大的幫忙,非常順利的設定完成(使用bridge方式)
有稍微測試一下,發現MOD開機的時候,讀取頻道速度稍微變慢,Router CPU使用率還OK。
之後再撥空使用大大另外推薦的EOIP方式看看,感謝

TOP

本帖最後由 gfx86674 於 2019-7-19 02:51 編輯

回復 16# asd82242002
謝謝您的指教,錯誤的確在pvid沒加。
已修正內文,請您再嘗試設置。

另外若遇到/interface bridge vlan新增後不允許儲存,
有可能是預設啟用的fast forward正在運作不允許變更port,
只要在bridge關閉它(取消勾選)即可。
附件: 您需要登錄才可以下載或查看附件。沒有帳號?註冊

TOP

回復 14# gfx86674

感謝大大熱心回覆
今天下午撥空小試了一下,結果發現PPPOE部份似乎沒有設定好,導致不能正常上網。DHCP部份有分配到區IP,所以沒問題。
另外想請教一下,interface bridge port 有需要各別設置pvid嗎?
還是只要interface bridge vlan設定好就可以呢?

TOP

本帖最後由 gfx86674 於 2019-7-18 16:23 編輯

EOIP的做法:
  1. #RB750Gr3(A)
  2. /interface bridge
  3. add name=bridge-wan protocol-mode=none
  4. add name=bridge-lan

  5. /ip address
  6. add address=192.168.255.254/31 interface=bridge-wan network=192.168.255.254
  7. add address=192.168.88.1/24 interface=bridge-lan network=192.168.88.0

  8. /interface eoip
  9. add local-address=192.168.255.254 name=eoip remote-address=192.168.255.255 tunnel-id=75

  10. /interface bridge port
  11. add bridge=bridge-wan interface=ether1 hw=yes
  12. add bridge=bridge-wan interface=ether4 hw=yes
  13. add bridge=bridge-wan interface=ether5 hw=yes
  14. add bridge=bridge-lan interface=ether2 hw=no
  15. add bridge=bridge-lan interface=ether3 hw=no
  16. add bridge=bridge-lan interface=eoip

  17. /ip dhcp-server
  18. add address-pool=dhcp-pool authoritative=after-2sec-delay interface=bridge-lan name=DHCP

  19. /interface pppoe-client
  20. add allow=pap interface=bridge-wan keepalive-timeout=60 profile=default name=pppoe-out1 password=xxxx user=xxxx
複製代碼
  1. #RB750Gr3(B)
  2. /interface bridge
  3. add name=bridge-wan protocol-mode=none
  4. add name=bridge-lan

  5. /ip address
  6. add address=192.168.255.255/31 interface=bridge-wan network=192.168.255.254
  7. add address=192.168.88.2/24 interface=bridge-lan network=192.168.88.0

  8. /interface eoip
  9. add local-address=192.168.255.255 name=eoip remote-address=192.168.255.254 tunnel-id=75

  10. /interface bridge port
  11. add bridge=bridge-wan interface=ether5 hw=yes
  12. add bridge=bridge-wan interface=ether4 hw=yes
  13. add bridge=bridge-wan interface=ether1 hw=no
  14. add bridge=bridge-lan interface=ether2 hw=no
  15. add bridge=bridge-lan interface=ether3 hw=no
  16. add bridge=bridge-lan interface=eoip
複製代碼
EOIP 與#14樓vlan運作上有何差異呢?
RB750Gr3的switch chip(MT7621)雖無vlan table,但仍俱port switch功能。
所以EOIP的目的即IPTV廣播交由MT7621處理;CPU則只要負責處理Lan的封包就好。

而#13樓CPU則全全負責IPTV與Lan,不只是CPU處理IPTV封包有疑慮,
CPU滿載時IPTV與Lan也會互有誰的封包優先進出,造成干擾...

Lan的封包排後頂多是延遲,但IPTV封包一延遲則所有不利媒體的問題則會通通跑出來。
這也是我不信任bridge vlan的原因。

TOP

本帖最後由 gfx86674 於 2019-7-24 13:02 編輯

回復 13# asd82242002
設定方式不一樣,bridge vlan有專屬的作法。
若把#1樓範例的兩台Router都換成RB750Gr3需要這樣做:
  1. #RB750Gr3(A)
  2. /interface bridge add name=bridge

  3. /interface bridge port
  4. add bridge=bridge interface=ether1 hw=no pvid=100
  5. add bridge=bridge interface=ether2 hw=no pvid=200
  6. add bridge=bridge interface=ether3 hw=no pvid=200
  7. add bridge=bridge interface=ether4 hw=no pvid=100
  8. add bridge=bridge interface=ether5 hw=no

  9. /interface bridge vlan
  10. add bridge=bridge tagged=bridge,ether5 untagged=ether1,ether4 vlan-ids=100
  11. add bridge=bridge tagged=bridge,ether5 untagged=ether2,ether3 vlan-ids=200

  12. /interface vlan
  13. add name=wan vlan-id=100 interface=bridge
  14. add name=lan vlan-id=200 interface=bridge

  15. /ip address
  16. add address=192.168.88.1/24 interface=lan network=192.168.88.0

  17. /interface bridge
  18. set bridge vlan-filtering=yes

  19. /ip dhcp-server
  20. add address-pool=dhcp-pool authoritative=after-2sec-delay interface=lan name=DHCP

  21. /interface pppoe-client
  22. add allow=pap interface=wan keepalive-timeout=60 profile=default name=pppoe-out1 password=xxxx user=xxxx
複製代碼
  1. #RB750Gr3(B)
  2. /interface bridge add name=bridge

  3. /interface bridge port
  4. add bridge=bridge interface=ether1 hw=no pvid=200
  5. add bridge=bridge interface=ether2 hw=no pvid=200
  6. add bridge=bridge interface=ether3 hw=no pvid=200
  7. add bridge=bridge interface=ether4 hw=no pvid=100
  8. add bridge=bridge interface=ether5 hw=no

  9. /interface bridge vlan
  10. add bridge=bridge tagged=bridge,ether5 untagged=ether4 vlan-ids=100
  11. add bridge=bridge tagged=bridge,ether5 untagged=ether1,ether2,ether3 vlan-ids=200

  12. /interface vlan
  13. add name=lan vlan-id=200 interface=bridge

  14. /ip address
  15. add address=192.168.88.2/24 interface=lan network=192.168.88.0

  16. /interface bridge
  17. set bridge vlan-filtering=yes
複製代碼
問題在於,當IPTV影像超過FHD(1080P),甚至達4K時...
RB750Gr3 CPU能否扛得住大廣播封包的轟炸,
扛不住可能會有影像破圖,聲音趕不上畫面,這類不悅的事件發生。

假如真的發生不幸怎麼辦,那也不倒是不能解決。
只不過需換個方式,不使用vlan,改使eoip tunnel即可。

TOP

回復 6# gfx86674


GFX大大您好
因為在還沒看到這篇文章前已購入了兩台RB750Gr3,若將本文的設置方式從switch vlan改為bridge vlan,是可行的嗎?

TOP

回復 11# gfx86674


    PoE能稳定hap ac2的双频wifi ?
    也许我可以把PoE用到房间的面板wifi上。
    准备购买!

TOP

回復 10# sssss2sssss
我的建議是RB450Gx4 + hap ac^2(俱IEEE802.11n與ac雙頻wifi )。
這兩組合switch chip皆為Atheros8327,
除vlan為主要需求可橋接外,還有PoE供電。

RB450Gx4 eth5有PoE output的功能,hap ac^2 eth2則支援PoE input。
所以只要將RB450Gx4的eth5,接上hap ac^2的eth2,
hap ac^2不需供電(不裝變壓器)就能從eth2取得電力工作。這很棒吧,不是嗎?

TOP

本帖最後由 sssss2sssss 於 2019-7-17 10:36 編輯

现有中国电信4k iptv。物理布局看起来相同。

想要达成一样的效果可以看4k iptv,换哪两种路由适合?

第一台路由需要能翻(v2ray)。

第二台路由客厅电视柜下,需要讯号比较强的。谢谢!

TOP

本帖最後由 gfx86674 於 2019-7-9 12:03 編輯

若橋接的不是RB750GL,而是RB260GS(SwOS)呢?
只要懂得vlan-heard與vlan-mode作用,其實是不會有困難的:




附件: 您需要登錄才可以下載或查看附件。沒有帳號?註冊

TOP

本帖最後由 gfx86674 於 2019-6-27 20:15 編輯
谢谢CHing信息,如果不用RB750Gr3,那么用哪个model比较适合呢?是否都要用RB450呢? ...
角色 發表於 2019-6-27 16:58

Manual:Switch Chip Features
低階的Router使用vlan盡量選擇有switch chip能力的。
高階的話有switch chip最好,但CPU強大到能用運算硬扛其實也沒問題。

RB450G已經夠老了,若只是想作為vlan用途,
還不如直接購買台vlan switch(如:Mikrotik RB260GS)還較便宜又實際。

TOP

谢谢CHing信息,如果不用RB750Gr3,那么用哪个model比较适合呢?是否都要用RB450呢?

TOP

本帖最後由 gfx86674 於 2019-6-27 01:22 編輯

06/27/2019更新switch chip vlan。

真心覺得諸位求便宜也不能收RB750Gr3,
CPU不能扛,連switch chip也是個半吊子(MT7621),買了肯定後悔。

TOP

返回列表