MikroTik hAP ac² - Script difference before and after for checking VPN tab box
Script difference before and after for checking VPN tab box
Listing 1: Before checking the VPN tab box- /interface bridge
- add admin-mac=CC:2D:E0:xx:xx:xx auto-mac=no comment=defconf name=bridge
- /interface wireless
- set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-AExxx1 \
- wireless-protocol=802.11
- set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=\
- MikroTik-AExxx2 wireless-protocol=802.11
- /interface list
- add comment=defconf name=WAN
- add comment=defconf name=LAN
- /interface wireless security-profiles
- set [ find default=yes ] supplicant-identity=MikroTik
- /ip pool
- add name=default-dhcp ranges=192.168.88.10-192.168.88.254
- /ip dhcp-server
- add address-pool=default-dhcp disabled=no interface=bridge name=defconf
- /interface bridge port
- add bridge=bridge comment=defconf interface=ether2
- add bridge=bridge comment=defconf interface=ether3
- add bridge=bridge comment=defconf interface=ether4
- add bridge=bridge comment=defconf interface=ether5
- add bridge=bridge comment=defconf interface=wlan1
- add bridge=bridge comment=defconf interface=wlan2
- /ip neighbor discovery-settings
- set discover-interface-list=LAN
- /interface list member
- add comment=defconf interface=bridge list=LAN
- add comment=defconf interface=ether1 list=WAN
- /ip address
- add address=192.168.88.1/24 comment=defconf interface=bridge network=192.168.88.0
- /ip dhcp-client
- add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
- /ip dhcp-server network
- add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
- /ip dns
- set allow-remote-requests=yes
- /ip dns static
- add address=192.168.88.1 name=router.lan
- /ip firewall filter
- add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
- add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
- add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
- add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
- add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,apices
- add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
- add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
- add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
- add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
- add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
- /ip firewall nat
- add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
- /system routerboard settings
- set silent-boot=no
- /tool mac-server
- set allowed-interface-list=LAN
- /tool mac-server mac-winbox
- set allowed-interface-list=LAN
- [admin@MikroTik] >
複製代碼 .
Listing 2: After checking the VPN tab box- /interface bridge
- add admin-mac=CC:2D:E0:xx:xx:xx auto-mac=no comment=defconf name=bridge
- /interface wireless
- set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-AExxx1 \
- wireless-protocol=802.11
- set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-AExxx2 \
- wireless-protocol=802.11
- /interface list
- add comment=defconf name=WAN
- add comment=defconf name=LAN
- /interface wireless security-profiles
- set [ find default=yes ] supplicant-identity=MikroTik
- /ip hotspot profile
- set [ find default=yes ] html-directory=flash/hotspot
- /ip pool
- add name=dhcp ranges=192.168.88.10-192.168.88.254
- add name=vpn ranges=192.168.89.2-192.168.89.255
- /ip dhcp-server
- add address-pool=dhcp disabled=no interface=bridge name=defconf
- /ppp profile
- set *FFFFFFFE local-address=192.168.89.1 remote-address=vpn
- /interface bridge port
- add bridge=bridge comment=defconf interface=ether2
- add bridge=bridge comment=defconf interface=ether3
- add bridge=bridge comment=defconf interface=ether4
- add bridge=bridge comment=defconf interface=ether5
- add bridge=bridge comment=defconf interface=wlan1
- add bridge=bridge comment=defconf interface=wlan2
- /ip neighbor discovery-settings
- set discover-interface-list=LAN
- /interface l2tp-server server
- set enabled=yes ipsec-secret=vpn-password use-ipsec=yes
- /interface list member
- add comment=defconf interface=bridge list=LAN
- add comment=defconf interface=ether1 list=WAN
- /interface pptp-server server
- set enabled=yes
- /interface sstp-server server
- set default-profile=default-encryption enabled=yes
- /ip address
- add address=192.168.88.1/24 comment=defconf interface=ether2 network=192.168.88.0
- /ip cloud
- set ddns-enabled=yes
- /ip dhcp-client
- add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
- /ip dhcp-server network
- add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
- /ip dns
- set allow-remote-requests=yes
- /ip dns static
- add address=192.168.88.1 name=router.lan
- /ip firewall filter
- add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
- add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 protocol=udp
- add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
- add action=accept chain=input comment="allow l2tp" dst-port=1701 protocol=udp
- add action=accept chain=input comment="allow pptp" dst-port=1723 protocol=tcp
- add action=accept chain=input comment="allow sstp" dst-port=443 protocol=tcp
- add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
- add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
- add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
- add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
- add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
- add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
- add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
- add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
- add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
- /ip firewall nat
- add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
- add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=192.168.89.0/24
- /ppp secret
- add name=vpn password=vpn-password
- /system routerboard settings
- set silent-boot=no
- /tool mac-server
- set allowed-interface-list=LAN
- /tool mac-server mac-winbox
- set allowed-interface-list=LAN
- [admin@MikroTik] >
複製代碼 .
The difference in code are- /ip pool
- add name=vpn ranges=192.168.89.2-192.168.89.255
- /ppp profile
- set *FFFFFFFE local-address=192.168.89.1 remote-address=vpn
- /ppp secret
- add name=vpn password=vpn-password
- /interface l2tp-server server
- set enabled=yes ipsec-secret=vpn-password use-ipsec=yes
- /interface pptp-server server
- set enabled=yes
- /interface sstp-server server
- set default-profile=default-encryption enabled=yes
- /ip cloud
- set ddns-enabled=yes
- /ip firewall filter
- add action=accept chain=input comment="allow IPsec NAT" dst-port=4500 protocol=udp
- add action=accept chain=input comment="allow IKE" dst-port=500 protocol=udp
- add action=accept chain=input comment="allow l2tp" dst-port=1701 protocol=udp
- add action=accept chain=input comment="allow pptp" dst-port=1723 protocol=tcp
- add action=accept chain=input comment="allow sstp" dst-port=443 protocol=tcp
- add action=masquerade chain=srcnat comment="masq. vpn traffic" src-address=192.168.89.0/24
複製代碼 |