返回列表 發帖
本帖最後由 mrandrewchan 於 2013-3-25 00:01 編輯

回復 48# bky16

I also try it. Buy a RB951G-2HnD......successful

Ref for DDNS - changeip.net

System > Scripts > +> input scripts name e.g. ddnschangeip
#以下程式碼於RouterOS 3.7下測試通過

:log info "DDNS: Begin"
:local ddnsuser "your domain name e.g.abc.changeip.net"
:local ddnspass "your login password"
:local ddnshost "your host name e.g. abc"
:local ddnszone "your zone e.g. changeip.net"
:local ddnsinterface "your access internet interface e.g ether_out1"
#一定要先宣告,不然後面程式無法使用
:global ddnslastip
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
#舊的IP有存在就用舊的,不存在就建0.0.0.0/0
:if ([:typeof [:global ddnslastip]] = nil ) do={ :global ddnslastip 0.0.0.0/0 } else={ :set ddnslastip $ddnslastip }
:if ([:typeof [:global ddnsip]] = nil ) do={
:log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
} else={
    :if ($ddnsip != $ddnslastip) do={
        :log info "DDNS: 開始更新DDNS!"
        :log info ([/tool dns-update key-name=$ddnsuser key=$ddnspass name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] zone=$ddnszone] . "更新IP:" . $ddnsip)

        :global ddnslastip $ddnsip
} else={
        :log info "DDNS: IP無變動"
}
}
:log info "DDNS: End"

system > Scheduler > + >  input schedule e.g.ddns_autoupdate
/system script rund ddnschangeip (name = create script name)
AC

TOP

本帖最後由 mrandrewchan 於 2013-3-25 00:34 編輯

回復 44# bky16
close un-use services

1. IP > services > disable e.g ftp, ssh, telenet, www....etc.
2. Double take the servcie e.g winbox,  then > Avaialbe From > input the ip address can be access

But don't know how to close port 53
AC

TOP

我都係買左兩星期, 大家互相學習, 我比交懶惰用WinBox Config, 好等我成功做到 VPN.. pptp, openvpn....一齊連吧, 我也在學中
AC

TOP

I think must confirm DNS server setting is correct.

In Winbox:
IP > DNS > input two DNS server IP  4.2.2.2 and 8.8.8.8 > apply > ok

Try again use in WinBox > Tools > ping > cn.yahoo.com

Remarks : may be is can't update the DDNS
AC

TOP

不明原因, 有冇其他 CHing 幫忙
AC

TOP

Yes,

You can create read only user for your frd access your RouterOS to check setting.

system > users > + > input user name e.g.guest > group : read > input password > confirm password
AC

TOP

Check without DNS input

IP > DNS > input 4.2.2.2 & 8.8.8.8
AC

TOP

回復 69# bky16
Please delet the guest account or disable
AC

TOP

回復 83# 角色
請教 CHing 以下圖 !  是什麼意思....謝
附件: 您需要登錄才可以下載或查看附件。沒有帳號?註冊
AC

TOP

回復 86# 角色
謝謝
AC

TOP

各位 CHing,  我 RouterOS 內沒有 10.x.x.x network,  為何會圖內出現,  並那哪裡可以查看或刪除.....   謝謝
附件: 您需要登錄才可以下載或查看附件。沒有帳號?註冊
AC

TOP

明白.....謝謝
AC

TOP

返回列表