Board logo

標題: 【RouterOS】——Dynamic DNS [打印本頁]

作者: 角色    時間: 2013-1-3 01:05     標題: 【RouterOS】——Dynamic DNS

本帖最後由 角色 於 2013-3-9 21:05 編輯

Sources of information: http://wiki.mikrotik.com/wiki/Dy ... e_Script_for_dynDNS

for example: DynDNS

1) add a script called dynDNS:
  1. # Define User Variables
  2. :global ddnsuser "DYNDNSUSER"
  3. :global ddnspass "DYNDNSPASS"
  4. :global ddnshost "DYNDNSHOST"

  5. # Define Global Variables
  6. :global ddnsip
  7. :global ddnslastip
  8. :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }

  9. :global ddnsinterface
  10. :global ddnssystem ("mt-" . [/system package get system version] )

  11. # Define Local Variables
  12. :local int

  13. # Loop thru interfaces and look for ones containing
  14. # default gateways without routing-marks
  15. :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
  16.   :if ([:typeof [/ip route get $int routing-mark ]] != str ) do={
  17.      :global ddnsinterface [/ip route get $int interface]
  18.   }
  19. }

  20. # Grab the current IP address on that interface.
  21. :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]

  22. # Did we get an IP address to compare?
  23. :if ([ :typeof $ddnsip ] = nil ) do={
  24.    :log info ("DynDNS: No ip address present on " . $ddnsinterface . ", please check.")
  25. } else={
  26.   :if ($ddnsip != $ddnslastip) do={
  27.     :log info "DynDNS: Sending UPDATE!"
  28.     :local str "/nic/update?hostname=$ddnshost&myip=$ddnsip&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
  29.     /tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser \
  30.         password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
  31.     :delay 1
  32.     :local str [/file find name="DynDNS.$ddnshost"];
  33.     /file remove $str
  34.     :global ddnslastip $ddnsip
  35.   }
  36. }
複製代碼
2) Add a scheduler entry to run every minute
  1. /system scheduler add name=dynDNS interval=00:01 on-event="/system script run dynDns\r\n"
複製代碼

作者: 角色    時間: 2013-1-5 16:00

是否有人用过MikroTik的DNS呢?怎样用都不成功。
作者: bubblestar    時間: 2013-1-5 17:45

我用這個的。
  1. # Set needed variables
  2. :local username "ddns_username"
  3. :local password "ddns_password"
  4. :local hostname "ddyns.hostname"

  5. :global dyndnsForce
  6. :global previousIP

  7. # print some debug info
  8. :log info ("UpdateDynDNS: username = $username")
  9. :log info ("UpdateDynDNS: password = $password")
  10. :log info ("UpdateDynDNS: hostname = $hostname")
  11. :log info ("UpdateDynDNS: previousIP = $previousIP")

  12. # get the current IP address from the internet (in case of double-nat)
  13. /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
  14. :delay 1
  15. :local result [/file get dyndns.checkip.html contents]

  16. # parse the current IP result
  17. :local resultLen [:len $result]
  18. :local startLoc [:find $result ": " -1]
  19. :set startLoc ($startLoc + 2)
  20. :local endLoc [:find $result "</body>" -1]
  21. :local currentIP [:pick $result $startLoc $endLoc]
  22. :log info "UpdateDynDNS: currentIP = $currentIP"

  23. # Remove the # on next line to force an update every single time - useful for debugging,
  24. # but you could end up getting blacklisted by DynDNS!

  25. #:set dyndnsForce true

  26. # Determine if dyndns update is needed
  27. # more dyndns updater request details http://www.dyndns.com/developers/specs/syntax.html

  28. :if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
  29.    :set dyndnsForce false
  30.    :set previousIP $currentIP
  31.    :log info "$currentIP or $previousIP"
  32.    /tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
  33.       src-path="nic/update?system=dyndns&hostname=$hostname&myip=$currentIP&wildcard=no" \
  34.       dst-path="/dyndns.txt"
  35.    :delay 1
  36.    :local result [/file get dyndns.txt contents]
  37.    :log info ("UpdateDynDNS: Dyndns update needed")
  38.    :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
  39.    :put ("Dyndns Update Result: ".$result)
  40. } else={
  41.    :log info ("UpdateDynDNS: No dyndns update needed")
  42. }
複製代碼

作者: 角色    時間: 2013-1-5 18:18

如果我用Version 3.x, 而bubblestar就用Version 5.x。而我的routerOS就是5.22,那么应该用Version 5.x比较适合。
作者: 角色    時間: 2013-1-5 18:18

如果我用Version 3.x, 而bubblestar就用Version 5.x。而我的routerOS就是5.22,那么应该用Version 5.x比较适合。
作者: 角色    時間: 2013-1-5 19:06

回復 3# bubblestar

都是不能update DDNS。

怎样加呢?

1) 用edit把script做成一个DynDNS-5x.txt,然后ftp到router。
2) 在router, /file print能看到DynDNS-5x.txt, 输入适当的credential
3) /system add script DynDNS-5x.txt,
4)  /system run 0 (where 0 is given by /system script print)
作者: bubblestar    時間: 2013-1-5 19:15

不知是否RouterOS 本身的問題,DDNS update 後,雖然見到新IP資料,但我差不多等了15分鐘左右,才能使用解決NAT loopback 問題,即是從local network,在Browser 內直接打 DDNS_Hostname 進入自己網內的NAS 資源。

感覺上RouterOS 的Update 沒有像一般Router一樣能即時反影新的設定。
作者: bubblestar    時間: 2013-1-5 19:22

但用SSL 方式,https://XXX.XXX.XXX:443 就可以馬上進入NAS 的資源,真不明所以。
而普通用 http://xxx.xxx.xxx:8080 用了一會又很容易斷掉 connection.。
作者: bubblestar    時間: 2013-1-6 12:57

假如是Dual Wan or Multiple Wan,如何把不同IP update 指向同一位址呢?
作者: lttliang    時間: 2013-1-22 10:20

解决未呀?
作者: 角色    時間: 2013-1-22 13:26

现在还没有成功,因为没有时间。
作者: bky16    時間: 2013-3-27 18:13

DDNS可以啦!

要确定係NEW TERMINAL度可以ping通域名
(这个经mrandrewchan CHING指导,原来係IP>DNS依度加8.8.8.8,唔好入去STATIC里面加)
行SCRIPT一定要搞掂依个,因为佢係透过DNS搵地址来UPDATE

其它,可以参照:
http://www.telecom-cafe.com/foru ... amp;extra=#pid32082

角色CHING可以update吓D教材啦!嘻嘻
作者: 角色    時間: 2013-3-28 21:24

本帖最後由 角色 於 2013-3-28 21:47 編輯

回復 3# bubblestar

bubblestar兄这个也可以。但是是取最前面的WAN口的IP (WAN 1 IP),而不是Routerbaord的WAN IP (WAN 2 IP)。如果只有Routerboard自己,那么最前的WAN IP就是RouterBoard的WAN IP。这个script使用RouterBoard在最前面。

还有这个都是一样,第一先建立一个文件,把新的IP address记下来,下次的IP个这个IP不一样,就做一次update。如果一样就是bypass,根据不去dyndns的server check一下,是否与本身的IP address是一样?如果一样,不update,不一样就update。

图一:多个Routers
[attach]2343[/attach]

图二:只有一个RB
[attach]2344[/attach]
作者: 角色    時間: 2013-9-8 14:42

刚才再看这张thread,问题是那个script,放在哪里呢?
作者: 雯雯    時間: 2013-9-8 14:46

回復 14# 角色

放在System -> Scripts裏.
作者: 角色    時間: 2013-9-8 15:16

不是放在Files?
作者: 角色    時間: 2013-9-8 15:34

按照#6帖的信息,然后manual行了一次都不行。
作者: 雯雯    時間: 2013-9-8 15:34

回復 16# 角色

不是.
作者: 角色    時間: 2013-9-8 16:10

我用的不是DYNDNS主要domain,而是它的sub-domain,所以script需要某种改变才可以。
作者: 角色    時間: 2013-9-8 17:40

回復 12# bky16

我怎样做都不行!真的纳闷!
作者: 角色    時間: 2013-9-8 18:06

原来的我加的script从来都没有excute过,因为我在log看不到logged messagess。
作者: 角色    時間: 2013-9-8 21:07

终于把Dynamic DNS搞好了。主要是怎样execute问题。

1. 先用Windows Editor把script copied 到Editor里,然后save a file name. Extension可以用什么都可以,一般txt,或者rsc。
2. 怎样execute是一个非常重要的问题,就是用
  1. /import file=script.rsc
複製代碼

作者: 角色    時間: 2013-9-8 21:14

本帖最後由 角色 於 2013-9-8 21:31 編輯

#1帖的code,出现error message
  1. [admin@MikroTik] > /import file-name=dyndns-1.rsc
  2. Opening script file dyndns-1.rsc

  3. Script file loaded successfullyinput does not match any value of value-name
  4. interrupted
  5. [admin@MikroTik] >
複製代碼

作者: 角色    時間: 2013-9-8 21:26

本帖最後由 角色 於 2013-9-8 21:32 編輯

#3帖的code,没有问题
  1. [admin@MikroTik] > /import file-name=dyndns-3.rsc
  2. Opening script file dyndns-3.rsc

  3.   status: finished

  4.   status: finished

  5. Dyndns Update Result: good 58.153.xxx.yyy
  6. Script file loaded and executed successfully
  7. [admin@MikroTik] >
複製代碼

作者: 角色    時間: 2013-9-8 21:31

本帖最後由 角色 於 2013-9-8 21:40 編輯

Another Script Link provided by member "bky16"
  1. ############
  2. # Set needed variables
  3. ############
  4. # Your DynDNS account user-name, password & host-name.
  5. :local username "yourusername"
  6. :local password "yourpassword"
  7. :local hostname "yourhostname"

  8. # Which interface are we checking if DHCP has changed? [interfaces | name column in winbox]
  9. :local DHCPInterface "yourinterface"
  10. ############
  11. # This is the name of the file where the last recorded IP will be stored, as well as the file name of the DynDNS response.
  12. # Make sure if another script is using files, that these names don't conflict.
  13. # You probably also want to be sure they aren't the same as any other files on the disk - because you'll be clobbering those files.
  14. # Finally, while I'm not aware of any "reserved" file names on the disk, it would be wise to avoid something that might conflict.
  15. # Prefixing them with something to associate them with this script would probably be a good thing.
  16. # You can point these files at your SD-disk too, if you have an SD card installed and ready on your RB. Just prefix the path appropriately:
  17. # something like this [:local vLastIPFileName "micro-sd/dyndns-lastip.txt"] (don't put a leading slash)
  18. # A user reported a bug if you use the RB flash and prefix the path with a [/]
  19. # So for RB based flash, it's probably safest to use just something like [:local vLastIPFileName "dyndns-lastip.txt"] and not [:local vLastIPFileName "/dyndns-lastip.txt"]
  20. # You ***MUST*** use a .txt extension. Just an oddity of ROS. Move along now.
  21. # Code ForDD
  22. :local vLastIPFileName "dyndns-lastip.txt"
  23. :local vDynDNSResponseFile "dyndns-resp.txt"
  24. # /dyndns.txt

  25. ############
  26. # END Set needed variables
  27. ############

  28. :local vlen;
  29. :local vRawIP;
  30. :local vJustIP;
  31. :local currentIP
  32. :local previousIP
  33. :local vlocalurl
  34. :local vIPChanged false
  35. :local dyndnsresult
  36. :local result

  37. # Check for file existance, if not create it
  38. # We need to do this before we try to read or write to files...
  39. :local check [/file find name=$vLastIPFileName]
  40. :if ( $check = "" ) do= {
  41.    /file print file=$vLastIPFileName
  42.    :delay 2
  43.    /file set [/file find name=$vLastIPFileName] contents=""
  44. }

  45. # Get the last saved IP from the file.
  46. :set previousIP [/file get $vLastIPFileName contents]
  47. #:put $previousIP


  48. # print some debug info
  49. :log info ("UpdateDynDNS: username = $username")
  50. :log info ("UpdateDynDNS: password = $password")
  51. :log info ("UpdateDynDNS: hostname = $hostname")
  52. :log info ("UpdateDynDNS: previousIP = $previousIP")
  53. :log info ("UpdateDynDNS: DHCPInterface = $DHCPInterface")


  54. # This code gets the current IP from the interface.
  55. # The interface we're checking should be set above.
  56. # get the raw IP from the interface, which includes a mask.
  57. :set vRawIP [:tostr [/ip address get [find interface=$DHCPInterface] address]]

  58. #Strip the netmask off the vRawIP address.
  59. :for i from=( [:len $vRawIP] - 1) to=0 do={
  60.         :if ( [:pick $vRawIP $i] = "/") do={
  61.                 :set vJustIP [:pick $vRawIP 0 $i]
  62.         }
  63. }
  64. :set currentIP $vJustIP

  65. # Determine if dyndns update is needed
  66. # more dyndns updater request details http://www.dyndns.com/developers/specs/syntax.html
  67. # Update if the currentIP isn't equal to previousIP.
  68. :if (($currentIP != $previousIP)) do={
  69.         :log info "CurrentIP: $currentIP - PreviousIP: $previousIP"
  70.         :set vlocalurl ("http://" . "$username" . ":" . "$password" . "@" . "members.dyndns.org" . "/nic/update?hostname=" . "$hostname" . "&myip=" . "$currentIP")   
  71.         /tool fetch mode=http url=$vlocalurl dst-path=$vDynDNSResponseFile
  72.         :set result [/file get $vDynDNSResponseFile contents]
  73.         :set vIPChanged true
  74. } else={
  75.    :log info ("UpdateDynDNS: No dyndns update needed")
  76. }

  77. # Get the result status code and pull it out for use.
  78. # IF IPChanged = true
  79. #        Get result code
  80. #                Check DynDNS result
  81. #                if good or nochg, then
  82. #                        :set previousIP $currentIP
  83. #                        /file set [/file find name=$vLastIPFileName] contents="$currentIP"
  84. #                        also post the result to the log file        
  85. #                else badauth or !donator or notfqdn, nohost, abuse, dnserr, 911
  86. #                        post to log file
  87. #                        Don't update previousIP or vLastIPFileName file
  88. :if ($vIPChanged=true) do={
  89.         :set result [/file get $vDynDNSResponseFile contents]
  90.         :local endLoc [:find $result " " -1]
  91.         :set dyndnsresult [:pick $result -1 ($endLoc)]
  92.         :put $dyndnsresult
  93.                 :if (($dyndnsresult = "good") || ($dyndnsresult = "nochg") ) do={
  94.                         :set previousIP $currentIP
  95.                         :log info ("UpdateDynDNS: Dyndns update needed")
  96.                         :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
  97.                         /file set [/file find name=$vLastIPFileName] contents="$currentIP"
  98.                         } \
  99.                 else={
  100.                         :log info ("UpdateDynDNS: Dyndns update needed")
  101.                         :log info ("DynDNS Update FAILED")
  102.                         :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
  103.                 }
  104. }
複製代碼
  1. New Terminal> /system scheduler add name=dyndns interval=00:01 on-event="/system script run dyndns\r\n"
複製代碼
Result 也 Okay
  1. [admin@MikroTik] > /import dyndns-bk.rsc
  2. Opening script file dyndns-bk.rsc

  3.   status: finished

  4. good
  5. Script file loaded and executed successfully
  6. [admin@MikroTik] >
複製代碼

作者: 角色    時間: 2013-9-9 11:33

现在bky16的script,一关电源,过了一晚,再试就没有把DNS更改。

那么估计还要修改一下。
作者: 角色    時間: 2013-9-13 22:20

现在正在测试bubblestar兄的script,看看关机后,再开是否可以把ip upgrade到最新的IP。
作者: jerryzero    時間: 2013-9-19 10:09

我用1樓的SCRIPT去UPDATE DYNDNS, 幾個月前試都OK, 因為之前一直甪HKBB,所以IP都無轉過, 現在改用PCCW,就發現UPDATE唔到, 點睇SCRIPT是否成功.
角色C兄, 應該要把SCRIPT放到SCHEDULE去RUN, 我每幾分鐘RUN一次,
睇過SCHEDULE的確有RUN到, 但睇唔到個SCRIPT有無成功UPDATE..
作者: 角色    時間: 2013-9-19 22:15

我也发现这个问题,问题是整个script都是看local file,而不是check DNS Server!所以等我有空的时候去学怎样去修改那段script,看看是否做到script去check DNS Server。
作者: jerryzero    時間: 2013-9-20 19:06

我也发现这个问题,问题是整个script都是看local file,而不是check DNS Server!所以等我有空的时候去学怎 ...
角色 發表於 2013-9-19 22:15



    個script有check dyndns有無update到, 如果wan ip唔等於dyndns records就會update, 但係行完個script都無update到..
作者: 角色    時間: 2013-9-25 20:49

不知道其他members是否用的Script能关机后再能update DNS server呢?
作者: yiucsw    時間: 2015-1-4 05:26

我用了一个懒方法加DDNS NO-IP。 各位有没有更好的? 不知道如何 import File 内的 Script 到 System Script name, 所以将Script 直接打到 Source 后。没有 Read, Test 是不能运行,不知道有什么用处?

这是我的DDNS NOIP Script。
/system script add name=ddns-noip policy=write,read,policy,sensitive,test source={
:local DDNSuser "YYYYYY@gmail.com"
:local DDNSpass "PASSWORD"
:local DDNShost "XXXX.ddns.net"

# possible value are DynDNS, No-IP, ChangeIP;
:local DDNStype value="No-IP";

/tool fetch mode=http keep-result=yes url="http://myip.dnsomatic.com/index.html" dst-path="CURRip";
/delay delay-time=2s;
:local CURRip value=[:toip [/file get "CURRip" value-name=contents]];
/delay delay-time=2s;
/file remove "CURRip";

:if ([:resolve $DDNShost] != $CURRip) do={
:if ($DDNStype = "DynDNS") do={ /tool fetch mode=http keep-result=no url="http://members.dyndns.org/nic/update?hostname=$DDNShost&myip=$CURRip" user=$DDNSuser password=$DDNSpass; };
:if ($DDNStype = "No-IP") do={ /tool fetch mode=http keep-result=no url="http://dynupdate.no-ip.com/nic/update?hostname=$DDNShost&myip=$CURRip" user=$DDNSuser password=$DDNSpass; };
:if ($DDNStype = "ChangeIP") do={ /tool dns-update name=$DDNShost address=$CURRip key-name=$DDNSuser key=$DDNSpass; };
/log info message=($DDNStype.": Updating ".$DDNShost." to:".$CURRip);
};
}


以下是我的Scheduler
/system scheduler
add comment="Update No-IP DDNS" disabled=yes interval=600s name=ddns-noip on-event=ddns-noip policy=read,write,test,policy
作者: 角色    時間: 2015-1-4 11:18

效果怎样?你在大陆?
作者: tc30624100    時間: 2015-1-4 11:35

幾年前我記得大陸封左no-ip 架. 宜家又放生返啦?
作者: 角色    時間: 2015-1-4 11:47

DynDNS一样,主要主hostname xxx.dyndns.org当然被blocked,但是用dyndns的sub-domian就没有问题。由于要收费,所以已经全部停用了。
作者: tc30624100    時間: 2015-1-5 07:35

對啊 全面收費, 差點忘了呢.. 哈哈
作者: yiucsw    時間: 2015-1-5 10:00

在广州移动宽带。No-ip 能ACCESS/Update。只是对海外线慢的离谱。
已上的Script Policy 是有点问题。
作者: yiucsw    時間: 2015-1-5 22:34

失败了。No-IP 网站能Update 新的网址. 但ping/Nslookup 能发现新的网址不知道要多久。起码不止半小时。
作者: 角色    時間: 2015-1-5 23:30

那么奇怪?时能PM我的你的hostname,然后我从香港check一下看看?
作者: yiucsw    時間: 2015-1-6 11:06

我Login 香港的Router,ping/tracert hostname 都没有问题。NO-ip网址都更新。
所有是中国移动的DNS Server没有立刻更新。在中国也用不了8.8.8.8。。。等等。?没有办法去找最新的网址。
作者: 角色    時間: 2015-1-6 13:29

DNS用香港的Servers,就是你是香港的ISP给你的DNS server。
作者: fems    時間: 2015-1-7 18:25

本帖最後由 fems 於 2015-1-7 19:21 編輯

一直用DNSexit,免费稳定,也支持顶级域名。
更新脚本参考http://forum.mikrotik.com/viewtopic.php?t=65013修改一下即可,需指定wan口。
ROS6.24
[attach]3408[/attach]
[attach]3409[/attach]
  1. #************************************************************************************************
  2. # Parameters
  3. #************************************************************************************************
  4. :local username "<your username>"
  5. :local password "<your password>"
  6. :local hostname "<subdomain.yourprovider.net>"

  7. #availabe options: "http" or "iface"
  8. # - http: will query an external server and discover you public ip (userful for NATted connections)
  9. # - iface: will use the ip address assigned to the $iface interface (see below)

  10. :local discoverBy "iface"

  11. # interface used to get ip address from (only if discoverBy = iface)

  12. :local iface "public-dsl"

  13. # current available services: "dyndns", "noip" and "dnsexit"
  14. :local service "dnsexit"

  15. # number of days to force an update if your IP did not change (helps keeping your account active)
  16. :local forceUpdate 15

  17. #************************************************************************************************
  18. # do not change below this unless you know what you are doing
  19. #************************************************************************************************

  20. :local force
  21. :global lastUpdate
  22. :local currentIP

  23. :if ($discoverBy="http") do={
  24.    /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
  25.    :local result [/file get dyndns.checkip.html contents]
  26.    :local resultLen [:len $result]
  27.    :local startLoc [:find $result ": " -1]
  28.    :set startLoc ($startLoc + 2)
  29.    :local endLoc [:find $result "</body>" -1]
  30.    :set currentIP [:pick $result $startLoc $endLoc]
  31. } else={
  32.    :set currentIP [ /ip address get [find interface=$iface disabled=no] address ]
  33.    :for i from=( [:len $currentIP] - 1) to=0 do={
  34.       :if ( [:pick $currentIP $i] = "/") do={ :set currentIP [:pick $currentIP 0 $i] }
  35.    }
  36. }

  37. #get IP from DynDNS for our hostname
  38. :local resolvedIP [:resolve $hostname]

  39. # get current date in format mm/DD/YYYY
  40. :local date [ /system clock get date ]

  41. # convert to YYYYMMDD
  42. :local months ("jan","feb","mar","apr","may","jun","jul","aug","sep","oct","nov","dec");
  43. :local month [ :pick $date 0 3 ]; :local day [ :pick $date 4 6 ]; :local year [ :pick $date 7 11 ];
  44. :local mm ([ :find $months $month -1 ] + 1);
  45. :if ($mm < 10) do={ :set month ("0" . $mm); } else={ :set month $mm; }
  46. :set date ($year . $month . $day);

  47. :if ([ :typeof $lastUpdate ]=[:nothing] || (($date-$lastUpdate) >= $forceUpdate  && $forceUpdate > 0)) do={
  48.    :set force true
  49. }

  50. :put ("Current IP: $currentIP ($discoverBy), Last update: $lastUpdate")

  51. # Determine if dyndns update is needed
  52. :if (($currentIP != $resolvedIP) || ($force = true)) do={
  53.    
  54.     :if ($service = "dyndns") do={
  55.        /tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
  56.             src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/output.txt"
  57.     }
  58.     :if ($service = "noip") do={
  59.        /tool fetch user=$username password=$password mode=http address="dynupdate.no-ip.com" \
  60.             src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/output.txt"
  61.     }
  62.     :if ($service = "dnsexit") do={
  63.        /tool fetch user=$username password=$password mode=http address="update.dnsexit.com" \
  64.             src-path="/RemoteUpdate.sv?login=$username&password=$password&host=$hostname&myip=$currentIP" dst-path="/output.txt"
  65.     }
  66.    
  67.     :local result [/file get output.txt contents]
  68.     :log info ("dynamic-dns-updater: Service = $service, Hostname = $hostname")
  69.     :log info ("dynamic-dns-updater: CurrentIP = $currentIP, Resolved IP = $resolvedIP")
  70.     :log info ("dynamic-dns-updater: Update result: ".$result)
  71.     /ip dns cache flush
  72.     :set lastUpdate $date
  73. }
複製代碼

作者: yiucsw    時間: 2015-1-8 01:10

刚搬家所有有点不一样。知道原因:被派假IP 172.0.7.85。 在Log 没有Show.只有Quick Set Show 派的IP Address。PPTP/IPSEC/。。。 Server 都没有REAL IP 运行。
不知道能不能投诉。
作者: 角色    時間: 2015-1-8 01:43

因为是内部IP,不能在外面进入系统,所以要求更换Public IP。
我估计一般是给Private IP,如果有投诉才跟Public IP,估计电信估算很多人只是上网,而不需要public IP,所以给你private IP就算了。

所以你一定要投诉外面不可以登入!
作者: yiucsw    時間: 2015-1-8 10:57

刚投诉。没有Public IP便取消。另外加中国电信。




歡迎光臨 電訊茶室 (http://telecom-cafe.com/forum/) Powered by Discuz! 7.2